EthanMedia Status - Global CDN Performance Issues – Incident details

Global CDN Performance Issues

Resolved
Major outage
Started almost 3 years agoLasted 14 minutes
Updates
  • Resolved
    Resolved

    We just resolved the issue, There may be increased loads on origins than usual as CDN global systems quickly restore.

  • Identified
    Identified

    We are continuing to work on a fix for this incident. Issue has been identified.

  • Investigating
    Investigating

    We are currently investigating this issue.