EthanMedia Status - Edge Network DNS issues affecting a small number of users – Incident details

Edge Network DNS issues affecting a small number of users

Resolved
Degraded performance
Started 8 months agoLasted about 8 hours
Updates
  • Resolved
    Resolved

    This issue has been fixed.

  • Identified
    Identified

    We have identified the root cause of this issue, and are working on a fix.

    Some users are unable to resolve our nameservers and hosted DNS records.

  • Investigating
    Investigating

    We are currently investigating an issue where a very small amount of people can not access our CDN edge network.